KENTNL / Dist-Zilla-Util-SimpleMunge-1.000001 / Changes

Release history for Dist-Zilla-Util-FileMunge-Simple

1.000001 2014-04-27T11:41:40Z
 [Bugfix]
 - Minor documentation bugs with formatting.

1.000000 2014-04-27T11:25:29Z
 [00 Major]
 - This is a major set of changes, but mostly forwards compatible.
 - Only a few minor packaging backcompat risks for downstream $VENDORs who
   work by HAND.

 [01 DZil 5 Encoding Support]
 - Dist::Zilla >= 5.0 is now mandatory
 - Callback functions now pass an "encoding" value ( either 'text' or
   'bytes' )
 - This is mostly a pragmatic choice, if it can be decoded, you probably
   want to work with it decoded
 - Otherwise you'll probably want to work with it as bytes.

 [02 New Functions]
 - A whole bunch of new functions have been added which are more DWIM and
   trying smarter to advoid the horrible black magic. - auto_munge_file now
   the most recommended approach, but supports no laziness overiding.

 [03 Less Black Magic]
 - There's still a rebless trick or two to cast the refs in-place, but they
   should be more stable and less prone to initialization-based errors.

 [04 New Tooling]
 - ExtUtils::MakeMaker has taken precedence over Module::Build
 - Dependencies on latest versions are now only recommended, not required.

 [05 New Verson Scheme]
 - 0.y.z -> 1.yyyzzz
 - This is the primary reason for the 1.x on the box.

 [Dependencies::Aggregate]
 - 5.008 : 200
 - 5.010 : 183
 - 5.019 : 161

 [Dependencies::Stats]
 - Dependencies changed since 0.2.2, see Changes.deps{,.all,.dev} for
   details
 - build: -1
 - configure: +1 -1 (recommends: +1)
 - develop: +43 -2 (recommends: -1, suggests: +1 -1)
 - runtime: +3 ↑1
 - test: +5 ↓1 -2 (recommends: +4)

0.2.2 2013-05-15T15:32:05Z
 - Minor Maintenance release.

 [Dependencies::Stats]
 - Dependencies changed since 0.2.1, see Changes.deps{,.all,.dev} for
   details
 - build: ↑1
 - configure: ↑1
 - develop: +6 (suggests: ↑1)
 - test: ↑1

 [Documentation]
 - Add README.mkdn to src tree.
 - Update Copyright Year.

 [Meta]
 - Bug tracker to github issues.

 [Packaging]
 - Use MB 0.4004 test_requires

0.2.1 2012-05-09T07:58:41Z
 - Maintenance Release.

 [Dependencies::Stats]
 - Dependencies changed since 0.2.0, see Changes.deps{,.all,.dev} for
   details
 - develop: (recommends: ↑1, suggests: ↑1)
 - runtime: +1

 [Packaging]
 - Update LICENSE ( Year, Address , Indent )

 [Tests]
 - add minimum version test.

0.2.0 2011-10-09T06:46:42Z
 [Dependencies::Stats]
 - Dependencies changed since 0.1.2, see Changes.deps{,.all,.dev} for
   details
 - runtime: +2
 - test: -2

 [Features]
 - Exhaustive error reporting data and input validation. (
   0.1.2-source-3-g45a8173 )
 - Added type-coercion-in-munge support. ( 0.1.2-source-2-g23ded3 )

 [Tests]
 - Added test for type-coercion-in-munge ( 0.1.2-source-2-g23ded3 )

0.1.2 2011-10-07T18:44:02Z
 - First non-trial release now demonstratably able to do 99% of its
   intended task.

 [Dependencies::Stats]
 - Dependencies changed since 0.1.1, see Changes.deps{,.all,.dev} for
   details
 - test: +2

 [Tests]
 - Now tests the core munge behaviour via munge_file. (
   0.1.1-source-2-g8afd9ef )

0.1.1 2011-10-07T17:21:53Z
 [Internals]
 - Rehash native munging interface to be more flexible, optional, and
   extendable. ( 0.1.0-source-2-gd1911aa )

 [Packaging]
 - Try out not-yet-released patches to the Dzil Twitter Plugin for
   supporting -TRIAL

0.1.0 2011-10-07T05:33:55Z
 - First version, Proof of Concept, but not yet feature complete.




Hosting generously
sponsored by Bytemark