DRTECH / Elasticsearch-1.05 / Changes

Revision history for Elasticsearch

1.05    2014-03-05

        Deprecated the Elasticsearch namespace in favour of Search::Elasticsearch.
        See https://github.com/elasticsearch/elasticsearch-perl/issues/20

        Improved the Bulk->reindex() API. Now accepts a remote $es object.
        Improved documentation.
        Added Hijk backend.

1.04    2014-02-27

        Changed the default Cxn to HTTPTiny v0.043. Now provides persistent
        connections and is a lot faster than LWP.

        Changed ES::Scroll to pass the scroll_id in the URL instead of the
        body. Better support for older versions and servers behind caching
        proxies.

1.03    2014-02-12
        Fixed node sniffing to work across 0.90 and 1.0

1.02    2014-02-11
        Fixed bug in Elasticsearch::Scroll::next when called in scalar context

1.01    2014-02-09
        Fixed plugin loader to work with latest version of Module::Runtime
        which complains about undefined versions

1.00    2014-02-07
        API updated to be compatible with v1.x branch of Elasticsearch.

        BACKWARDS COMPATIBILITY: To use this client with versions of
        Elasticsearch before 1.x, specify the client version as:

            $es = Elasticsearch->new(
                client => '0_90::Direct'
            );

0.76    2013-12-02
        Added support for send_get_body_as GET/POST/source
        Added timeout to bulk API

0.75    2013-10-24
        Fixed the sniff regex to accommodate hostnames when present

0.74    2013-10-03
        Fixed a timeout bug in LWP with persistent connections
        and bad params when using https

0.73    2013-10-02
        Added Elasticsearch::Cxn::LWP
        Added Elasticsearch::TestServer
        Die with explanation if a user on a case-insensitive file system
        loads this module instead of ElasticSearch

0.72    2013-09-29
        Added Elasticsearch::Bulk and Elasticsearch::Scroll
        Changed `https` to `use_https` for compatibility with elasticsearch-py
        Numerous fixes for different Perl versions, and Moo 1.003 now required

0.71    2013-09-24
        Fixed dist.ini to list dependencies correctly

0.70    2013-09-24
        Bumped version numbers because CPAN clashes
        with ElasticSearch.pm

0.04    2013-09-23
        First release




Hosting generously
sponsored by Bytemark