3.1.3 - 2021-01-13

  • Fix Pod typo
  • Add bugtracker to metadata
  • Some refactoring to reduce code complexity

3.1.2 - 2018-12-23

  • We now need Perl 5.10.

3.1.1 - 2018-12-22

  • Bring all module version numbers into line.

3.1.0 - 2018-12-22

  • Various code improvements to please kritika.io
  • Added 'suggest' mode (thanks to Alex Balhatchet)

3.0.2 - 2016-12-07

  • Really made module versions consistant :-/

3.0.1 - 2016-12-07

  • Added repo information to Build.PL
  • Made module version numbers consistant
  • Declare required Perl version in Build.PL

3.0.0 - 2016-12-06

  • Various code improvements
  • Obscure bug fixes
  • Vastly imporved tests
  • Updated subroutine calls to stop using ampersands (ankit01ojha)
  • Removed old SVN cruft (danielksan81)
  • Replaced README with README.md (gaurav1911)
  • Fix testing module requirements

2.07 - 2008-06-30

  • Documentation fixes (from Philip Newton)

2.05/2.06 - 2008-03-06

  • More build fixes

2.04 - 2008-03-04

  • Fixed build issues in previous release

2.03 - 2008-03-03

  • Require Perl 5.6.0
  • Switch to using Module::Build
  • Switch to using Test::More

2.02 - 2005-10-22

  • Pod tests
  • Fixed tests (and added more)
  • Added more documentation

2.01 - 2004-10-30

  • Added README, more tests and plugin modules

2.00 - 2001-07-24

  • Added plugin architecture

1.60 - 2000-11-17

  • Renamed to Symbol::Approx::Sub
  • Use Devel::Symdump instead of GlobWalker

Ancient History

2000-11-09

  • Renamed to Approx::Sub

2000-10-30

  • Moved all the glob-walking stuff to GlobWalker.pm

2000-10-09

  • Some good stuff from Robin Houston
  • Don't assume we're being called from main package
  • Allow different packages to use different Approx semantics
  • More tests

2000-08-24

  • Initial verson of Sub::Approx