RJBS / Version-Requirements-0.101022 / Changes

Revision history for Version-Requirements

0.101022  2012-02-03 10:29:59 America/New_York
          DEPRECATED DEPRECATED DEPRECATED DEPRECATED

          Version::Requirements is still DEPRECATED

          deprecation is only warned-about if not doing core perl tests,
          to quiet them up for the sake of porters' sanity

0.101021  2011-12-30 15:39:56 America/New_York
          DEPRECATED DEPRECATED DEPRECATED DEPRECATED

          Version::Requirements is now DEPRECATED

          Use CPAN::Meta::Requirements, which is a drop-in replacement.

0.101020  2010-04-12 09:08:26 America/New_York
          add finalization with ->finalize and ->is_finalized

0.101010  2010-04-11 10:20:02 America/New_York
          add a public accepts_module version

0.100660  2010-03-07 13:05:59 America/New_York
          specify that we need version.pm 0.77

0.100630  2010-03-04 22:54:15 America/New_York
          do not lose ">= 0" requirements on merge

0.100530  2010-02-22 21:09:40 America/New_York
          add is_simple method to V:R
          as_string_hash will now simplify ">= 1, != 1" to "> 1"

0.100520  2010-02-21 23:15:34 America/New_York
          add_requirements method added (to merge V:R objects)
          clear_requirement method added
          from_hash_string method added
          clone method added
          required_modules method added

0.100510  2010-02-20 17:27:19 America/New_York
          first release!




Hosting generously
sponsored by Bytemark