- no changes since 2.23

    - require perl v5.8.0; tests for [perl #121196] break on 5.6.1, and
      I (rjbs) am not comfortable spending time determining whether the fault
      lies for a 15 year old version of perl

    - Better handling of attempts to load non-existent modules
    - Improvements to fields.pm documentation

    - Backport from bleadperl before 5.16.0 release
    - base no longer sets a module's $VERSION to "-1" when a module it
      loads does not define a $VERSION.
    - base no longer internally skips loading modules it has already
      loaded and instead relies on require to inspect %INC.

    - Bump version to 2.15 so base and fields have the same version again

    - fix problem with SIGDIE on perls < 5.10
    - Make @INC available in base.pm's error message when
      a module can't be found. See CPAN bug #28582.
    - Fix obscure bug introduced in 2.13 (Michael G Schwern)

    - push all classes at once in @ISA

2.12  Fri Jul  6 00:57:15 PDT 2007
    Test Features
    - Test that base.pm preserves $VERSION after real module loading.

    Bug Fixes
    - Last version broke the warning about inheriting fields.

2.11  Mon Jul  2 03:30:03 PDT 2007
    New Features
    - Inheriting from yourself causes a warning [bleadperl 29090]

    Bug Fixes
    - Silenced warning when a class with no fields inherits from a class with
      fields. [bleadperl 22208]
    - An intermediate class with no fields messes up private fields
      in the base class. [bleadperl 23266] [bleadperl 23267]
    * Loading a module via base.pm would mask a global $SIG{__DIE__} in
      that module. [bleadperl 31163]
    - A constant named FIELDS in a base class would confuse base.pm
      [bleadperl 31420]

    Documentation Improvements
    - Added a DIAGNOSTICS section [bleadperl 22748]
    - Minor typos [bleadperl 25261]
    - Better explain how base goes about loading classes.
    - State explicitly that non-file classes can be based on.
    - Document that import() is not called.

    Test Fixes
    - Fix tests for new disallowed hash key access error message in blead.

2.04 through 2.10 were only released with perl.

2.03 Sun Sep 14 20:01:48 PDT 2003
    * phashes produced via fields::new() will now not warn when used for
      forward compatibility purposes
    - Reformatting the docs to make them a bit more readable
    - Making it clear that fields::new() is usable with or without
    * Fixing inheritance from classes which have only private fields
    * Fixing inheritance when an intermediate class has no fields.
      [perlbug 20020326.004]
    - Removing uses of 'our' from tests for backwards compat.

2.02 Wed Sep  3 20:40:13 PDT 2003
    - Merging the core fields.t test and my own long ago forked base.t test
      into fields-base.t combining all tests

2.01 Thu Aug 28 13:39:32 PDT 2003
    - Forgot to set the INSTALLDIRS to 'perl'

2.0  Wed Aug 27 21:47:51 PDT 2003
    * Separated from Class::Fields