- A hotfix release: local::lib was not bundled in the previous release.

- NOTICE: Remove $PERLBREW_ROOT/Conf.pm if it's there, and re-run `perlbrew mirror`
- perlbrew help system is changing. `perlbrew help <command>` now displays brief documentation for the command.
- Add a global `--root` argument for all commands that can be used as a quick alternative to set PERLBREW_ROOT env var.
- Avoid display paths to external/system perl in the output of `perlbrew list`
- Replace Text::Levenshtein with a minimal implementation -- the standalone executable get to be smaller.

- New command: lib
  - local::lib integration is done with this command.
- New command: install-patchperl
- skip runs of 'exec' on aliases https://github.com/gugod/App-perlbrew/pull/135
- Respect -f flag when installing to replace an already installed perl.
- Redefine the default value of -q flag to be false, and define it's meaning to be "complete silent"

- The installer now honors $TMPDIR (RT #70850)
- Fixd GH #108. `perlbrew use` has a fallback for users that does not use bash/csh -compitable shell.
- Deprecate the command 'perlbrew use system' simply use 'perlbrew off' or 'perlbrew switch-off' instead.
- Deprecate the special case of `perlbrew use /path/to/bin/perl` and `perlbrew switch /path/to/bin/perl
  - perlbrew no longer cast magic to external perls. But there will be an alternative.

- fixes for cpantester
- Fix 'switch' and 'use' for bash users, by Woody2143++
- The standalone `perlbrew` file is now packed with fatpacker, by running `dev-bin/build.sh`. `perl Makefile.PL` does no trigger a re-build anymore.
- Update the installer to grab patchperl 0.46

- Hotfix for `perlbrew install` command

- Fix GH #119 
- Fix t/08.exit_status.t for cpantesters
- Fix several bugs in `exec` command
- Implement GH #103 - install -v shows build.log
- Add -Dusedevel when installing blead perl

- suggest when user types wrong commands. hoelzro++
- Improvements about self-upgrade by hoelzro++
- exit with non-zero status code when there's some sort of error. by punytan++
- Added verification of existing alias before attempting unalias. johncm++
- Fix `install-cpanm` for due to a recenet github cert update. kanetann++

- Done GH #92 -- Show error messages on network errors.
- Fix GH #82 -- deduplicate items in PATH for the `list` command.
- Tests for various commands and methods.

- dependency fixes
- Fix auto-detection of curl
- Support OpenBSD pdksh. The provided bashrc should be compatible with pdksh.
- Small improvement of 'exec' command. `perlbrew exec perl -v` now works.

- Fix ccache support on Linux with bash.. GH #87.
- `install` command no longer clobbers existing installations.
- New commands: uninstall, alias, self-upgrade
- See more on http://perlbrew.pl/Release-0.22.html

- oylenshpeegul++ Let version numbers alone mean installation names. For example, 5.12.3 means perl-5.12.3
- audreyt++ fixed `perlbrew install <URL>` that might installs to a wrong path.
- Fix RT #68241
- Improve `perlbrew list` command output
- Improve `perlbrew install` command. Now it takes a local .tar.gz filename
- See more detail in http://perlbrew.pl/Release-0.21.html

- For more detail release note, see https://github.com/gugod/App-perlbrew/wiki/Relesae-0.20
- doherty++ FIX: stop when user specified an invalid perl version that cannot be found on cpan.
- doherty++ specialized version installation: perlbrew install perl-blead / <URL>
- am0c++ FIX: `perlbrew intsall /path/to/git/src/dir`

- Auto run 'perlbrew init' after an install (or upgrade)
- Symlink dev versions of executables. For example,'perl5.13.11' to 'perl', 'prove5.13.11' to 'prove'.
- Automatically apply patches necessary to make older perls build again on
  modern platforms with the help of Devel::PatchPerl.
- A command "perlbrew available" to list recently available perls to build by trcjr

- Spotted and fixed by chad.a.davis++, an issue when bash set "noclobber" option,
  which breaks the creation of ~/.perlbrew/init. See https://rt.cpan.org/Ticket/Display.html?id=66518
- A simple `perlbrew clean` command to clean build dir.
- delegate `-j` arg value to `make test_harness`. by dagolden++
- $HOME is replaced with "~" in many messages. https://rt.cpan.org/Ticket/Display.html?id=57668

- UPDATE NOTES: you need to init, off and switch back to the version you want;
- Fix "perlbrew use" to work even if we are switched to a specific version
- Fix "perlbrew env" to use current version, sets PERLBREW_PERL and proper PATH
- Feature: "perlbrew use" shows current version in use
- Feature: "perlbrew switch /path/to/special/perl name-of-special-perl" names for adhoc perl's
- 'perlbrew exec' now excludes those non-brewed perl by frankcuny++ according to the discussion here: https://github.com/gugod/App-perlbrew/pull/43

- Use 'test_harness' for perl >= 5.7.3. avar++
- Use gtar on Solaris - RT #61042. doherty++
- Fix "perlbrew -f switch" by dalinaum++

- DEPRECATE and REMOVE 'perlbrew installed' command.
- Intrudoce a 'perlbrew exec' command
- 'perlbrew use system' can be used to locally turn off perlbrew. yibe++

- DEPRECATE `get_current_perl` function. Use `current_perl` instead
- Show versions of non-perlbrew perls in the output of `perlbrew list`. Thanks to trcjr++
- bashrc fixes from yibe++
- Let help, -h and --help do the same thing -- showing full pod.

- 'installed' command is renamed to 'list', and will be deprecated soon.
- Requires curl or wget from now -- to fetch https URLs. polettix++

- Fix: missing init file generation.

- Avoid warning messages. Thanks Anno Siegel for the bug report and patch.
- `-A` arguments are passed thru, thanks to gfx++.
- Unbreak tests for older perls with older Test::Simple. Thanks to zaphod42++
- Better bash Integration, no more 'hash -r'
- New command for bash and zsh: 'perlbrew use'
- Deprecating 'installed'. use 'list' instead.

- Use File::Path::Tiny to avoid the api incompatibility of File::Path.
- yanick++ and castaway++ fixes docmentation
- gfx++ made it accept -Dopt style flags as Perl Configurate does.
- (Danijel Tasov)++ added '-n' option -- no test!
- xsawyerx++ fixes RT #57672, #60123, and GH #9
- Fixes #59729

- Use the proxy set in $ENV{http_proxy} if available.
- Bypasses '-U' option to to configure. Thanks to chromatic++

- Conf file + CPAN mirror support
- Strip invalid dependency lines out of the makefile in older perl versions, to make them work with newer gcc versions
- Add rudimentary pure-perl introspection, jrockway++
- Documentation, castaway++

- Document about PERLBREW_ROOT and the issue installing it with CPAN.
- Handle an edge case whn the tarball is not found on the http server. Thanks to sekimura++
- Improves 'switch' and 'off' command message. Thanks to Justin Davis.
- PERL5OPT PERL5LIB are removed while configuring and testing a new perl. Thanks to Andrew Rodland.
- fix a expression precedence bug. Thanks to Jesse Luehrs.

- Fix -as option. Thanks to doy++ and jasonmay++

- Now it brews from git. jasonmay++
- Fix the uses of mkpath on various versions of perls.
- Support the building of 5.13, and future developement versions

- Use File::Path::mkpath instead of make_path to make in runnable with older versions of Perl
- a few document typo fixes.

- Fixed a bug that switch fail after 'off'

- Officially prepare a standalone program for quick download.
- license changed to "Same as Perl" due to the fact HTTP::Lite is included
- The 'installed' command now also lists all the 'perl' found in your PATH
- The 'switch' command can take an executable like /usr/bin/perl
- Various program options by Chris Prather
- Fixes from Tatsuhiko Miyagawa

- First release. Installs perl-5.11.[12345] on my mac.