++ed by:

1 non-PAUSE user.

Natal Ngétal
and 1 contributors

NAME

Dancer::Plugin::RequireSSL - Configure your application to redirect all incoming requests to HTTPS

VERSION

version 0.121370

SYNOPSIS

    use Dancer ':syntax';
    use Dancer::Plugin::RequireSSL;

    require_ssl();

    get '/' => sub {
        template index;
    }

METHODS

require_ssl

    require_ssl();

Redirect all incoming requests to https.

    input: none
    output: none

CONFIGURATION

  plugins:
    RequireSSL:
      hsts_age: 31536000
      hsts_include_subdomains: 0

CONTRIBUTING

This module is developed on Github at:

http://github.com/hobbestigrou/Dancer-Plugin-RequireSSL

ACKNOWLEDGEMENTS

Inspired by flask-sslify developed by Kenneth Reitz

BUGS

Please report any bugs or feature requests in github.

SUPPORT

You can find documentation for this module with the perldoc command.

    perldoc Dancer::Plugin::RequireSSL

SEE ALSO

Dancer

AUTHOR

Natal Ngétal

COPYRIGHT AND LICENSE

This software is copyright (c) 2012 by Natal Ngétal.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.