++ed by:
TEAM

1 PAUSE user

Lukas Mai
and 1 contributors

NAME

IO::Async::Loop::AnyEvent2::ElectricBoogaloo - load IO::Async::Loop::AnyEvent

SYNOPSIS

 use IO::Async::Loop::AnyEvent2::ElectricBoogaloo;

 my $loop = IO::Async::Loop::AnyEvent->new();
 ...

DESCRIPTION

This module lets you load IO::Async::Loop::AnyEvent with AnyEvent 6.1/7.

Unfortunately, IO::Async::Loop::AnyEvent currently fails its tests because it's being sabotaged by AnyEvent, so you have to force the install (e.g. using cpan -T IO::Async::Loop::AnyEvent or cpanm --notest IO::Async::Loop::AnyEvent).

After that, IO::Async::Loop::AnyEvent2::ElectricBoogaloo should install normally.

NOTES

The code to sabotage IO::Async::Loop::AnyEvent first appeared in AnyEvent 6.1 (it was not present in AnyEvent 6.02). It was later modified in 6.11, and again in AnyEvent 7.0. As of 2016, the code is still there.

SEE ALSO

IO::Async::Loop::AnyEvent, IO::Async, AnyEvent

AUTHOR

Lukas Mai, <l.mai at web.de>

COPYRIGHT & LICENSE

Copyright 2011, 2016 Lukas Mai.

This program is free software; you can redistribute it and/or modify it under the terms of either: the GNU General Public License as published by the Free Software Foundation; or the Artistic License.

See http://dev.perl.org/licenses/ for more information.