The Perl Toolchain Summit needs more sponsors. If your company depends on Perl, please support this very important event.

NAME

Solaris::SMF::Service - Encapsulate Solaris 10 services in Perl

VERSION

Version 0.02

SYNOPSIS

Interface to Sun's Service Management Facility in Solaris 10. This module provides a wrapper around 'svcs', 'svcadm' and 'svccfg'.

The SMF in Solaris is a replacement for inetd as well as the runlevel-based stopping and starting of daemons. Service definitions are stored in an XML database.

The biggest advantages in using SMF are the resiliency support, consistent interface and inter-service dependencies it offers. Services that die for any reason can be automatically restarted by the operating system; all services can be enabled or disabled using the same commands; and services can be started as soon as all the services they depend upon have been started, rather than at a fixed point in the boot process.

METHODS

new

Create a new Service object. The parameter must be a valid, unique FMRI.

status

Get the current status of this service. Returns a string, 'disabled', 'enabled', 'offline'.

FMRI

Returns the Fault Managed Resource Identifier for this service.

properties

Returns all or some properties for this service.

property

Returns the value of a single property of this service.

property_type

Returns the type of a single property of this service.

AUTHOR

Brad Macpherson, <brad at teched-creations.com>

BUGS

Please report any bugs or feature requests to bug-solaris-smf at rt.cpan.org, or through the web interface at http://rt.cpan.org/NoAuth/ReportBug.html?Queue=Solaris-SMF. I will be notified, and then you'll automatically be notified of progress on your bug as I make changes.

SUPPORT

You can find documentation for this module with the perldoc command.

    perldoc Solaris::SMF::Service

You can also look for information at:

ACKNOWLEDGEMENTS

COPYRIGHT & LICENCE

Copyright 2009 Brad Macpherson.

This program is free software; you can redistribute it and/or modify it under the terms of either: the GNU General Public Licence as published by the Free Software Foundation; or the Artistic Licence.

See http://dev.perl.org/licenses/ for more information.