++ed by:
KEEDI PERLANCAR AWNCORP

3 PAUSE users
7 non-PAUSE users.

Laurent Dami
and 1 contributors

NAME

DBIx::DataModel::Compatibility::V1 - compatibility with previous versions 1.*

SYNOPSIS

Do not use this package directly; use indirectly through

  use DBIx::DataModel -compatibility => 1.0;

DESCRIPTION

Version 2 of DBIx::DataModel was a major refactoring from versions 1.*, with a number of incompatible changes in the API (classes renamed, arguments renamed or reorganized, etc..).

The present package injects a compatibility layer between your application and DBIx::DataModel : that layer intercepts the calls and modifies the arguments and/or return values so that the API is compatible with prior versions 1.*.

For the moment, this compatibility layer is automatically activated, in order to automatically preserve backwards compatibility. Some time in the future, the compatibility layer will be deprecated, and will need to be explicitly required, as shown above in the synopsis.

If you want to explicitly disable the compatibility layer, write

  use DBIx::DataModel -compatibility => undef;

SEE ALSO

DBIx::DataModel

TODO

  - modify the @INC hook so that yaml files continue to work even if they
    contain class specs like 

     - !!perl/hash:DM::AutoView::DM::Const_avocat_JOIN_avocat 

  - check compat. with GEJDM::View.pm (link to Clone.pm)