++ed by:

3 PAUSE users
1 non-PAUSE user.

Erik Colson
and 12 contributors


Finance::Quote::mstaruk - Obtain UK Unit Trust quotes from morningstar.co.uk.


    $q = Finance::Quote->new;

    %info = Finance::Quote->fetch("mstaruk","<isin> ...");  # Only query morningstar.co.uk using ISINs
    %info = Finance::Quote->fetch("ukfunds","<isin> ...");  # Failover to other sources


This module fetches information from the MorningStar Funds service, http://morningstar.com/uk/. There are many UK Unit Trusts and OEICs quoted, as well as many Offshore Funds and Exhange Traded Funds (ETFs). It converts any funds quoted in GBX (pence) to GBP, dividing the price by 100 in the process.

Funds are identified by their ISIN code.

This module is loaded by default on a Finance::Quote object. It's also possible to load it explicity by placing "mstaruk" in the argument list to Finance::Quote->new().

Information obtained by this module may be covered by funds.ft.com terms and conditions See http://morningstar.co.ukfor details.

Stocks And Indices

This module provides both the "mstaruk" and "ukfunds" fetch methods for fetching UK and Offshore Unit Trusts and OEICs prices and other information from funds.ft.com. Please use the "ukfunds" fetch method if you wish to have failover with future sources for UK and Offshore Unit Trusts and OEICs - the author has plans to develop Finance::Quote modules for other source providing unit trust prices. Using the "mstaruk" method will guarantee that your information only comes from the morningstar.co.uk website.


The following labels may be returned by Finance::Quote::mstaruk :

    name, currency, last, date, time, price, nav, source, method,
    iso_date, net, p_change, success, errormsg.


Morning Star websites, http://morningstar.co.uk


Martin Sadler, <martinsadler@users.sourceforge.net>


Copyright (C) 2010 by Martin Sadler

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.10.1 or, at your option, any later version of Perl 5 you may have available.