++ed by:

2 non-PAUSE users.

Author image Felipe Gasper
and 1 contributors

NAME

Promise::ES6::Mojo - Promises/A+-compliant promises for Mojolicious

DEPRECATION NOTICE

This module is deprecated and will go away eventually. Use use_event() instead, as described in Promise::ES6’s documentation.

DESCRIPTION

This module exposes the same functionality as Promise::ES6::AnyEvent but for Mojo::IOLoop rather than AnyEvent.

Its interface is almost compatible with the ES6-derived portions of Mojo::Promise, but note that Mojo::Promise’s all() and race() methods accept a list of promises rather than an array reference.

NOTE: This module requires Mojolicious version 4.85 or higher.