無限健一
and 1 contributors

NAME

rvm.pl

WARNING!

This is an unstable development release not ready for production!

VERSION

Version 0.03.04

SYNOPSIS

rvm.pl will provide a subset of the bash rvm.

INSTALL RUBY

It is recommended to use Ruby::VersionManager with local::lib to avoid interference with possibly installed system ruby. Ruby::VersionManager comes with a script rvm.pl with following options.

list

List available ruby versions.

    rvm.pl list

updatedb

Update database of available ruby versions.

    rvm.pl updatedb

install

Install a ruby version. If no version is given the latest stable release will be installed. The program tries to guess the correct version from the provided string. It should at least match the major release. If you need to install a preview or rc version you will have to provide the full exact version.

Latest ruby

    rvm.pl install

Latest ruby-1.8

    rvm.pl install 1.8

Install preview

    rvm.pl install ruby-1.9.3-preview1

LIMITATIONS AND TODO

Currently Ruby::VersionManager is only running on Linux with bash installed. Support of gemsets and uninstall needs to be added.

AUTHOR

Mugen Kenichi, <mugen.kenichi at uninets.eu>

BUGS

Report bugs at:

SUPPORT

  • Technical support

    <mugen.kenichi at uninets.eu>