NAME

FP::Repl::Dependencies - hack to load Repl dependencies

SYNOPSIS

    use Chj::TEST use=> 'FP::Repl::Dependencies';

DESCRIPTION

Term::ReadLine::Gnu does not allow to check for its presence directly. When require'ing Term::ReadLine::Gnu, it gives an error saying "It is invalid to load Term::ReadLine::Gnu directly.". That makes it appear as unloadable when in fact it is present. And depending on just Term::ReadLine is not enough, the repl will then fail at runtime. Stupid.

So, this.

NOTE

This is alpha software! Read the status section in the package README or on the website.