++ed by:
KOVENSKY MJGARDNER BESSARABV RSIMOES BERZINV

117 PAUSE users
45 non-PAUSE users.

Ricardo SIGNES 😄

NAME

Dist::Zilla::Plugin::Prereq - list simple prerequisites

VERSION

version 4.101740

SYNOPSIS

In your dist.ini:

  [Prereq]
  Foo::Bar = 1.002
  MRO::Compat = 10
  Sub::Exporter = 0

Which is equivalent to specifying prerequisites for the Runtime phase:

  [Prereq / RuntimeRequires]
  Foo::Bar = 1.002
  MRO::Compat = 10
  Sub::Exporter = 0

See "Phases" for the full list of supported phases.

DESCRIPTION

This module adds "fixed" prerequisites to your distribution. These are prereqs with a known, fixed minimum version that doens't change based on platform or other conditions.

You can specify prerequisites for different phases and kinds of relationships. In RuntimeRequires, the phase is Runtime and the relationship is Requires. These are described in more detail in the CPAN::Meta specification.

The phases are:

  • configure

  • build

  • test

  • runtime

  • develop

The relationship types are:

  • requires

  • recommends

  • suggests

  • conflicts

Not all of these phases are useful for all tools, especially tools that only understand version 1.x CPAN::Meta files.

AUTHOR

Ricardo SIGNES <rjbs@cpan.org>

COPYRIGHT AND LICENSE

This software is copyright (c) 2010 by Ricardo SIGNES.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.