Author image Thierry Hamon
and 1 contributors

NAME

Lingua::YaTeA::ChunkingDataSet - Perl extension for the set of chuncking data

SYNOPSIS

  use Lingua::YaTeA::ChunkingDataSet;
  Lingua::YaTeA::ChunkingDataSet->new($file_set);

DESCRIPTION

The module implements sets of chunking data, i.e. chunking frontiers (field ChunkingFrontiers), chunking exceptions (field ChunkingExceptions), cleaning frontiers (CleaningFrontiers), and cleaning exceptions (CleaningExceptions). Chunking data are stored in subsets (Lingua::YaTeA::ChunckingSubset).

METHODS

new()

    new($file_set);

The method creates a set of chunking data and the related subset. The data stored in the directory c<$file_set> (an object Lingua::FileSet) are loaded in the subsets.

loadData()

    loadData($file_set);

The method loads the chuncking data stored in the directory c<$file_set> (an object Lingua::FileSet) in the related subsets: chunking frontiers (field ChunkingFrontiers), chunking exceptions (field ChunkingExceptions), cleaning frontiers (CleaningFrontiers), and cleaning exceptions (CleaningExceptions).

getSubset()

    getSubset($name);

The method returns the subset corresponding to the field $name (i.e. ChunkingFrontiers, ChunkingExceptions, CleaningFrontiers, CleaningExceptions).

existData()

    existData($set,$type,$data);

The methods checks if the data $data exists in the field $type in the subset $set. It returns 1 if it exists, otherwise 0.

SEE ALSO

Sophie Aubin and Thierry Hamon. Improving Term Extraction with Terminological Resources. In Advances in Natural Language Processing (5th International Conference on NLP, FinTAL 2006). pages 380-387. Tapio Salakoski, Filip Ginter, Sampo Pyysalo, Tapio Pahikkala (Eds). August 2006. LNAI 4139.

AUTHOR

Thierry Hamon <thierry.hamon@univ-paris13.fr> and Sophie Aubin <sophie.aubin@lipn.univ-paris13.fr>

COPYRIGHT AND LICENSE

Copyright (C) 2005 by Thierry Hamon and Sophie Aubin

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.8.6 or, at your option, any later version of Perl 5 you may have available.