++ed by:

4 non-PAUSE users.

Tom Wyant
and 1 contributors

TITLE

preaccepts - See whether specified versions of Perl accept a given regular expression

SYNOPSIS

 preaccepts '/x{' 5.025 5.025001 5.026 5.027 5.027001
 preaccepts -help
 preaccepts -version

OPTIONS

-help

This option displays the documentation for this script. The script then exits.

-version

This option displays the version of this script. The script then exits.

DETAILS

This Perl script accepts as its first argument a Perl regular expression, and as its second and subsequent arguments Perl verions numbers. It displays to standard out whether or not each given version of Perl considers the specified regular expression to be correct.

The heavy lifting for this is done by the PPIx::Regexp accepts_perl() method.

AUTHOR

Thomas R. Wyant, III wyant at cpan dot org

COPYRIGHT AND LICENSE

Copyright (C) 2017-2019 by Thomas R. Wyant, III

This program is free software; you can redistribute it and/or modify it under the same terms as Perl 5.10.0. For more details, see the full text of the licenses in the directory LICENSES.

This program is distributed in the hope that it will be useful, but without any warranty; without even the implied warranty of merchantability or fitness for a particular purpose.