# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.024.
use strict;
use warnings;

use 5.010;

use ExtUtils::MakeMaker;

my %WriteMakefileArgs = (
  "ABSTRACT" => "Bitcoin cryptography in Perl",
  "AUTHOR" => "Bartosz Jarzyna <bbrtj.pro\@gmail.com>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0
  },
  "DISTNAME" => "Bitcoin-Crypto",
  "LICENSE" => "perl",
  "MIN_PERL_VERSION" => "5.010",
  "NAME" => "Bitcoin::Crypto",
  "PREREQ_PM" => {
    "Bitcoin::BIP39" => "0.002",
    "CryptX" => "0.074",
    "Math::BigInt" => "1.999808",
    "Moo" => "2.003004",
    "Type::Tiny" => "1.004000",
    "namespace::clean" => "0.27"
  },
  "TEST_REQUIRES" => {
    "Test::Exception" => 0,
    "Test::More" => "0.88"
  },
  "VERSION" => "1.006",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = (
  "Bitcoin::BIP39" => "0.002",
  "CryptX" => "0.074",
  "Math::BigInt" => "1.999808",
  "Moo" => "2.003004",
  "Test::Exception" => 0,
  "Test::More" => "0.88",
  "Type::Tiny" => "1.004000",
  "namespace::clean" => "0.27"
);


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);