# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.012.
use strict;
use warnings;



use ExtUtils::MakeMaker;

my %WriteMakefileArgs = (
  "ABSTRACT" => "Find or Build libcmark-gfm",
  "AUTHOR" => "Dylan William Hardison <dylan\@hardison.net>",
  "BUILD_REQUIRES" => {
    "Alien::Build" => "0.32",
    "Alien::Build::MM" => "0.32",
    "ExtUtils::MakeMaker" => "6.52"
  },
  "CONFIGURE_REQUIRES" => {
    "Alien::Build" => "1.08",
    "Alien::Build::MM" => "0.32",
    "Alien::Build::Plugin::Build::CMake" => "0.99",
    "Alien::Build::Plugin::Download::Git" => "0.01",
    "Alien::Build::Plugin::Extract::Directory" => "0.65",
    "Alien::Build::Plugin::Fetch::Git" => "0.01",
    "Alien::Build::Plugin::Prefer::SortVersions" => "0.65",
    "ExtUtils::MakeMaker" => "6.52"
  },
  "DISTNAME" => "Alien-libcmark_gfm",
  "LICENSE" => "perl",
  "NAME" => "Alien::libcmark_gfm",
  "PREREQ_PM" => {},
  "VERSION" => "3.0",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = (
  "Alien::Build" => "0.32",
  "Alien::Build::MM" => "0.32",
  "ExtUtils::MakeMaker" => "6.52"
);


# BEGIN code inserted by Dist::Zilla::Plugin::AlienBuild
use Alien::Build::MM;
my $abmm = Alien::Build::MM->new;
%WriteMakefileArgs = $abmm->mm_args(%WriteMakefileArgs);
# END code inserted by Dist::Zilla::Plugin::AlienBuild


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);


# BEGIN code inserted by Dist::Zilla::Plugin::AlienBuild
sub MY::postamble {
  $abmm->mm_postamble;
}
# END code inserted by Dist::Zilla::Plugin::AlienBuild