Modules

Generate a Makefile.PL containing a warning for legacy users