Changes for version 0.02
- Changed name of "each" to "every", which seems to be gramatically more appropriate compared to its function.
- Added a lot of documentation that was still missing.
- Removed the threads::shared::cond_wait() hijacking code: no longer necessary because new signal setting code in Thread::Signal.
- Increased dependency on Thread::Signal to 1.05, to make use of the new signal setting code that should also work in cond_wait().
report stack status of all running threads