4 results (0.035 seconds)
Kent Fredric
Documentation
gentoo-perlmod-version.pl - Command line utility for translating cpan versions to gentoo equivalents.
Modules
Gentoo::PerlMod::Version - Convert arbitrary Perl Modules' versions into normalised Gentoo versions.
Gentoo::PerlMod::Version::Env - Get/parse settings from %ENV
Gentoo::PerlMod::Version::Error - Various error message and diagnostic bits.
Changes for version 0.6.0
  • 00 IMPORTANT CHANGES
    • $perlver being undef now is an error.
    • All error code is now refactored into the ::Error class, which ultimately grants more flexibility and better code organisation.
    • %ENV interaction is now handled vis a few utility functions in the ::Env class.
    • Functions in ::Env and ::Error are proxied into the ::Version class via some lazy-load functions.
  • Dependencies::Build::Changed
    • requires : Module::Build 0.3601 -> 0.4003
  • Dependencies::Configure::Changed
    • requires : Module::Build 0.3601 -> 0.4003
  • Dependencies::Develop::Changed
    • suggests : Dist::Zilla::PluginBundle::Author::KENTNL v1.3.0 -> v1.5.0
  • Dependencies::Test::Changed
    • requires : Test::More 0.96 -> 0.98
  • Dependencies::Test::New
    • requires : Scalar::Util
  • Documentation
    • Miscelaneous improvements, s/method/func/, and more general coverage of some error functions.



Hosting generously
sponsored by Bytemark