---
abstract: 'Perl bindings for neovim'
author:
  - 'Jacques Germishuys <jacquesg@cpan.org>'
build_requires:
  Archive::Tar: '0.0'
  Archive::Zip: '0.0'
  File::Path: '0'
  File::Slurper: '0.0'
  File::Spec: '0'
  File::Spec::Functions: '0'
  File::Temp: '0'
  File::Which: '0.0'
  HTTP::Tiny: '0.0'
  IO::Handle: '0'
  IPC::Open3: '0'
  Proc::Background: '0.0'
  Test::More: '0'
  Test::Pod: '0.0'
  Test::Pod::Coverage: '0.0'
  lib: '0'
  perl: '5.010'
configure_requires:
  Class::Accessor: '0.34'
  Eval::Safe: '0.02'
  ExtUtils::MakeMaker: 6.63_03
  IO::Async: '0.74'
  MsgPack::Raw: '0.01'
  perl: '5.022'
dynamic_config: 0
generated_by: 'Dist::Zilla version 6.014, CPAN::Meta::Converter version 2.150010'
license: perl
meta-spec:
  url: http://module-build.sourceforge.net/META-spec-v1.4.html
  version: '1.4'
name: Neovim-Ext
provides:
  Neovim::Ext:
    file: lib/Neovim/Ext.pm
    version: '0.05'
  Neovim::Ext::Buffer:
    file: lib/Neovim/Ext/Buffer.pm
    version: '0.05'
  Neovim::Ext::Buffers:
    file: lib/Neovim/Ext/Buffers.pm
    version: '0.05'
  Neovim::Ext::Common:
    file: lib/Neovim/Ext/Common.pm
    version: '0.05'
  Neovim::Ext::Current:
    file: lib/Neovim/Ext/Current.pm
    version: '0.05'
  Neovim::Ext::ErrorResponse:
    file: lib/Neovim/Ext/ErrorResponse.pm
    version: '0.05'
  Neovim::Ext::Funcs:
    file: lib/Neovim/Ext/Funcs.pm
    version: '0.05'
  Neovim::Ext::LuaFuncs:
    file: lib/Neovim/Ext/LuaFuncs.pm
    version: '0.05'
  Neovim::Ext::MsgPack::RPC:
    file: lib/Neovim/Ext/MsgPack/RPC.pm
    version: '0.05'
  Neovim::Ext::MsgPack::RPC::AsyncSession:
    file: lib/Neovim/Ext/MsgPack/RPC/AsyncSession.pm
    version: '0.05'
  Neovim::Ext::MsgPack::RPC::EventLoop:
    file: lib/Neovim/Ext/MsgPack/RPC/EventLoop.pm
    version: '0.05'
  Neovim::Ext::MsgPack::RPC::Response:
    file: lib/Neovim/Ext/MsgPack/RPC/Response.pm
    version: '0.05'
  Neovim::Ext::MsgPack::RPC::Session:
    file: lib/Neovim/Ext/MsgPack/RPC/Session.pm
    version: '0.05'
  Neovim::Ext::MsgPack::RPC::Stream:
    file: lib/Neovim/Ext/MsgPack/RPC/Stream.pm
    version: '0.05'
  Neovim::Ext::Plugin:
    file: lib/Neovim/Ext/Plugin.pm
    version: '0.05'
  Neovim::Ext::Plugin::Host:
    file: lib/Neovim/Ext/Plugin/Host.pm
    version: '0.05'
  Neovim::Ext::Plugin::ScriptHost:
    file: lib/Neovim/Ext/Plugin/ScriptHost.pm
    version: '0.05'
  Neovim::Ext::Range:
    file: lib/Neovim/Ext/Range.pm
    version: '0.05'
  Neovim::Ext::Remote:
    file: lib/Neovim/Ext/Remote.pm
    version: '0.05'
  Neovim::Ext::RemoteApi:
    file: lib/Neovim/Ext/RemoteApi.pm
    version: '0.05'
  Neovim::Ext::RemoteMap:
    file: lib/Neovim/Ext/RemoteMap.pm
    version: '0.05'
  Neovim::Ext::RemoteSequence:
    file: lib/Neovim/Ext/RemoteSequence.pm
    version: '0.05'
  Neovim::Ext::Tabpage:
    file: lib/Neovim/Ext/Tabpage.pm
    version: '0.05'
  Neovim::Ext::Tie::Stream:
    file: lib/Neovim/Ext/Tie/Stream.pm
    version: '0.05'
  Neovim::Ext::VIMCompat:
    file: lib/Neovim/Ext/VIMCompat.pm
    version: '0.05'
  Neovim::Ext::VIMCompat::Buffer:
    file: lib/Neovim/Ext/VIMCompat/Buffer.pm
    version: '0.05'
  Neovim::Ext::VIMCompat::Window:
    file: lib/Neovim/Ext/VIMCompat/Window.pm
    version: '0.05'
  Neovim::Ext::Window:
    file: lib/Neovim/Ext/Window.pm
    version: '0.05'
requires:
  Attribute::Handlers: '0'
  Carp: '0'
  Class::Accessor: '0'
  Eval::Safe: '0'
  Exporter: '0'
  IO::Async::Loop: '0'
  IO::Async::Signal: '0'
  IO::Async::Stream: '0'
  IO::Handle: '0'
  IO::Socket::INET: '0'
  IO::Socket::UNIX: '0'
  IPC::Open3: '0'
  List::Util: '0'
  MsgPack::Raw: '0'
  Scalar::Util: '0'
  Socket: '0'
  Tie::Array: '0'
  Tie::Hash: '0'
  Time::HiRes: '0'
  base: '0'
  overload: '0'
  perl: '5.010'
  strict: '0'
  warnings: '0'
resources:
  bugtracker: https://github.com/jacquesg/p5-Neovim-Ext/issues
  repository: git://github.com/jacquesg/p5-Neovim-Ext.git
version: '0.05'
x_Dist_Zilla:
  perl:
    version: '5.030001'
  plugins:
    -
      class: Dist::Zilla::Plugin::GatherDir
      config:
        Dist::Zilla::Plugin::GatherDir:
          exclude_filename: []
          exclude_match: []
          follow_symlinks: 0
          include_dotfiles: 0
          prefix: ''
          prune_directory: []
          root: .
      name: '@Author::JACQUESG/GatherDir'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::PruneCruft
      name: '@Author::JACQUESG/PruneCruft'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::ManifestSkip
      name: '@Author::JACQUESG/ManifestSkip'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::MetaYAML
      name: '@Author::JACQUESG/MetaYAML'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::License
      name: '@Author::JACQUESG/License'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::Readme
      name: '@Author::JACQUESG/Readme'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::ExtraTests
      name: '@Author::JACQUESG/ExtraTests'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::ExecDir
      name: '@Author::JACQUESG/ExecDir'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::ShareDir
      name: '@Author::JACQUESG/ShareDir'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::Manifest
      name: '@Author::JACQUESG/Manifest'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::TestRelease
      name: '@Author::JACQUESG/TestRelease'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::ConfirmRelease
      name: '@Author::JACQUESG/ConfirmRelease'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::GitHub::Meta
      name: '@Author::JACQUESG/@GitHub/GitHub::Meta'
      version: '0.47'
    -
      class: Dist::Zilla::Plugin::GitHub::Update
      config:
        Dist::Zilla::Plugin::GitHub::Update:
          metacpan: 1
      name: '@Author::JACQUESG/@GitHub/GitHub::Update'
      version: '0.47'
    -
      class: Dist::Zilla::Plugin::Git::NextVersion
      config:
        Dist::Zilla::Plugin::Git::NextVersion:
          first_version: 0.01
          version_by_branch: 0
          version_regexp: (?^:^v(.+)$)
        Dist::Zilla::Role::Git::Repo:
          git_version: 2.28.0
          repo_root: .
      name: '@Author::JACQUESG/Git::NextVersion'
      version: '2.046'
    -
      class: Dist::Zilla::Plugin::MetaConfig
      name: '@Author::JACQUESG/MetaConfig'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::MetaJSON
      name: '@Author::JACQUESG/MetaJSON'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::AutoPrereqs
      name: '@Author::JACQUESG/AutoPrereqs'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::PodVersion
      name: '@Author::JACQUESG/PodVersion'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::PkgVersion
      name: '@Author::JACQUESG/PkgVersion'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::NextRelease
      name: '@Author::JACQUESG/NextRelease'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::Test::Compile
      config:
        Dist::Zilla::Plugin::Test::Compile:
          bail_out_on_fail: '0'
          fail_on_warning: author
          fake_home: 0
          filename: t/00-compile.t
          module_finder:
            - ':InstallModules'
          needs_display: 0
          phase: test
          script_finder:
            - ':PerlExecFiles'
          skips: []
          switch: []
      name: '@Author::JACQUESG/Test::Compile'
      version: '2.058'
    -
      class: Dist::Zilla::Plugin::Test::CheckManifest
      name: '@Author::JACQUESG/Test::CheckManifest'
      version: '0.04'
    -
      class: Dist::Zilla::Plugin::PodSyntaxTests
      name: '@Author::JACQUESG/PodSyntaxTests'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::PodCoverageTests
      name: '@Author::JACQUESG/PodCoverageTests'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::Git::Commit
      config:
        Dist::Zilla::Plugin::Git::Commit:
          add_files_in: []
          commit_msg: v%V%n%n%c
        Dist::Zilla::Role::Git::DirtyFiles:
          allow_dirty:
            - Changes
            - dist.ini
          allow_dirty_match: []
          changelog: Changes
        Dist::Zilla::Role::Git::Repo:
          git_version: 2.28.0
          repo_root: .
        Dist::Zilla::Role::Git::StringFormatter:
          time_zone: local
      name: '@Author::JACQUESG/Git::Commit'
      version: '2.046'
    -
      class: Dist::Zilla::Plugin::Git::Tag
      config:
        Dist::Zilla::Plugin::Git::Tag:
          branch: ~
          changelog: Changes
          signed: 0
          tag: v0.05
          tag_format: v%V
          tag_message: '%N %v'
        Dist::Zilla::Role::Git::Repo:
          git_version: 2.28.0
          repo_root: .
        Dist::Zilla::Role::Git::StringFormatter:
          time_zone: local
      name: '@Author::JACQUESG/Git::Tag'
      version: '2.046'
    -
      class: Dist::Zilla::Plugin::Git::Push
      config:
        Dist::Zilla::Plugin::Git::Push:
          push_to:
            - origin
          remotes_must_exist: 1
        Dist::Zilla::Role::Git::Repo:
          git_version: 2.28.0
          repo_root: .
      name: '@Author::JACQUESG/Git::Push'
      version: '2.046'
    -
      class: Dist::Zilla::Plugin::UploadToCPAN
      name: '@Author::JACQUESG/UploadToCPAN'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::InstallRelease
      name: '@Author::JACQUESG/InstallRelease'
      version: '0.008'
    -
      class: Dist::Zilla::Plugin::Clean
      name: '@Author::JACQUESG/Clean'
      version: '0.07'
    -
      class: Dist::Zilla::Plugin::Prereqs
      config:
        Dist::Zilla::Plugin::Prereqs:
          phase: configure
          type: requires
      name: ConfigureRequires
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::Prereqs
      config:
        Dist::Zilla::Plugin::Prereqs:
          phase: test
          type: requires
      name: TestRequires
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::MinimumPerl
      name: MinimumPerl
      version: '1.006'
    -
      class: Dist::Zilla::Plugin::MetaProvides::Package
      config:
        Dist::Zilla::Plugin::MetaProvides::Package:
          finder_objects:
            -
              class: Dist::Zilla::Plugin::FinderCode
              name: MetaProvides::Package/AUTOVIV/:InstallModulesPM
              version: '6.014'
          include_underscores: 0
        Dist::Zilla::Role::MetaProvider::Provider:
          $Dist::Zilla::Role::MetaProvider::Provider::VERSION: '2.002004'
          inherit_missing: '1'
          inherit_version: '1'
          meta_noindex: '1'
        Dist::Zilla::Role::ModuleMetadata:
          Module::Metadata: '1.000036'
          version: '0.006'
      name: MetaProvides::Package
      version: '2.004003'
    -
      class: inc::MakeMaker
      config:
        Dist::Zilla::Plugin::MakeMaker:
          make_path: make
          version: '6.014'
        Dist::Zilla::Plugin::MakeMaker::Awesome:
          version: '0.48'
        Dist::Zilla::Role::TestRunner:
          default_jobs: 1
          version: '6.014'
      name: MakeMaker
      version: ~
    -
      class: Dist::Zilla::Plugin::PruneFiles
      name: PruneFiles
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':InstallModules'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':IncModules'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':TestFiles'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':ExtraTestFiles'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':ExecFiles'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':PerlExecFiles'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':ShareFiles'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':MainModule'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':AllFiles'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':NoFiles'
      version: '6.014'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: MetaProvides::Package/AUTOVIV/:InstallModulesPM
      version: '6.014'
  zilla:
    class: Dist::Zilla::Dist::Builder
    config:
      is_trial: '0'
    version: '6.014'
x_generated_by_perl: v5.30.1
x_serialization_backend: 'YAML::Tiny version 1.73'
x_spdx_expression: 'Artistic-1.0-Perl OR GPL-1.0-or-later'