# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.021.
use strict;
use warnings;

use 5.020;

use ExtUtils::MakeMaker 6.78;

my %WriteMakefileArgs = (
  "ABSTRACT" => "write command line apps with less suffering",
  "AUTHOR" => "Ricardo Signes <rjbs\@semiotic.systems>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => "6.78"
  },
  "DISTNAME" => "App-Cmd",
  "LICENSE" => "perl",
  "MIN_PERL_VERSION" => "5.020",
  "NAME" => "App::Cmd",
  "PREREQ_PM" => {
    "Capture::Tiny" => "0.13",
    "Carp" => 0,
    "Class::Load" => "0.06",
    "Data::OptList" => 0,
    "File::Basename" => 0,
    "Getopt::Long" => "2.39",
    "Getopt::Long::Descriptive" => "0.084",
    "IO::TieCombine" => 0,
    "Module::Pluggable::Object" => 0,
    "Pod::Usage" => "1.61",
    "String::RewritePrefix" => 0,
    "Sub::Exporter" => 0,
    "Sub::Exporter::Util" => 0,
    "Sub::Install" => 0,
    "Text::Abbrev" => 0,
    "constant" => 0,
    "experimental" => 0,
    "parent" => 0,
    "strict" => 0,
    "warnings" => 0
  },
  "TEST_REQUIRES" => {
    "Data::Dumper" => 0,
    "ExtUtils::MakeMaker" => 0,
    "File::Spec" => 0,
    "IPC::Cmd" => 0,
    "Test::Fatal" => 0,
    "Test::More" => "0.96",
    "lib" => 0
  },
  "VERSION" => "0.334",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = (
  "Capture::Tiny" => "0.13",
  "Carp" => 0,
  "Class::Load" => "0.06",
  "Data::Dumper" => 0,
  "Data::OptList" => 0,
  "ExtUtils::MakeMaker" => 0,
  "File::Basename" => 0,
  "File::Spec" => 0,
  "Getopt::Long" => "2.39",
  "Getopt::Long::Descriptive" => "0.084",
  "IO::TieCombine" => 0,
  "IPC::Cmd" => 0,
  "Module::Pluggable::Object" => 0,
  "Pod::Usage" => "1.61",
  "String::RewritePrefix" => 0,
  "Sub::Exporter" => 0,
  "Sub::Exporter::Util" => 0,
  "Sub::Install" => 0,
  "Test::Fatal" => 0,
  "Test::More" => "0.96",
  "Text::Abbrev" => 0,
  "constant" => 0,
  "experimental" => 0,
  "lib" => 0,
  "parent" => 0,
  "strict" => 0,
  "warnings" => 0
);


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);