# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v5.024.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Module::Build" => "0.28"
  },
  "dist_abstract" => "provide mango helpers to Mojolicious",
  "dist_author" => [
    "Huo Linhe <huolinhe\@berrygenomics.com>"
  ],
  "dist_name" => "Mojolicious-Plugin-Mango",
  "dist_version" => "0.0.2",
  "license" => "perl",
  "module_name" => "Mojolicious::Plugin::Mango",
  "recommends" => {},
  "recursive_test_files" => 1,
  "requires" => {
    "Mango" => 0,
    "Modern::Perl" => 0,
    "Mojo::Base" => 0,
    "namespace::clean" => 0
  },
  "script_files" => [],
  "test_requires" => {
    "Module::Find" => 0,
    "Mojolicious::Lite" => 0,
    "Test::Mojo" => 0,
    "Test::More" => 0,
    "Test::Pod" => 0,
    "Try::Tiny" => 0
  }
);


my %fallback_build_requires = (
  "Module::Build" => "0.28",
  "Module::Find" => 0,
  "Mojolicious::Lite" => 0,
  "Test::Mojo" => 0,
  "Test::More" => 0,
  "Test::Pod" => 0,
  "Try::Tiny" => 0
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);

$build->create_build_script;