Dist::Zilla::Plugin::Conflicts - Declare conflicts for your distro

This module lets you declare conflicts on other modules (usually dependencies of your module) in your dist.ini. Declaring conflicts does several thing to your distro. First, it generates a module named something like "Your::Distro::Conflicts". This m...

DROLSKY/Dist-Zilla-Plugin-Conflicts-0.19 - 20 Aug 2016 18:12:55 GMT - Search in distribution

Dist::Zilla::Plugin::Git::CheckFor::MergeConflicts - Check your repo for merge-conflicted files

This is a simple Dist::Zilla plugin to check that the gathered files contain no merge conflict markers....

RSRCHBOY/Dist-Zilla-PluginBundle-Git-CheckFor-0.014 - 10 Oct 2016 15:28:32 GMT - Search in distribution

lcpan - Manage your local CPAN mirror

This application is a convenient bundling of "CPAN::Mini" and an indexer so in addition to creating your local CPAN mirror and installing modules from it, you can also query various things about your local CPAN mirror quickly from the command-line (a...

PERLANCAR/App-lcpan-1.012 - 01 Nov 2016 06:01:26 GMT - Search in distribution

pdrutil - Collection of utilities for perl dist repos

This utility operates on a single Perl distribution repository....

PERLANCAR/App-PDRUtils-0.07 - 07 Oct 2016 08:18:17 GMT - Search in distribution

list-dist-deps - List dependencies from dist.ini

Check the Prereqs/* sections in your "dist.ini" and list them. There is an option to do recursive CPAN dependencies by using "lcpan". AutoPrereqs is not supported....

PERLANCAR/App-DzilUtils-0.11 - 10 Mar 2016 08:53:38 GMT - Search in distribution

cpanfile - A format for describing CPAN dependencies for Perl applications

"cpanfile" describes CPAN dependencies required to execute associated Perl code....

MIYAGAWA/Module-CPANfile-1.1002 - 12 Feb 2016 16:24:13 GMT - Search in distribution

Locale::TextDomain - Perl Interface to Uniforum Message Translation

The module Locale::TextDomain(3pm) provides a high-level interface to Perl message translation. Textdomains When you request a translation for a given string, the system used in libintl-perl follows a standard strategy to find a suitable message cata...

GUIDO/libintl-perl-1.26 - 13 Jun 2016 09:07:53 GMT - Search in distribution

Dist::CheckConflicts - declare version conflicts for your dist

One shortcoming of the CPAN clients that currently exist is that they have no way of specifying conflicting downstream dependencies of modules. This module attempts to work around this issue by allowing you to specify conflicting versions of modules ...

DOY/Dist-CheckConflicts-0.11 - 03 Apr 2014 14:58:28 GMT - Search in distribution

Dist::Zilla::Plugin::Prereqs - list simple prerequisites

This module adds "fixed" prerequisites to your distribution. These are prereqs with a known, fixed minimum version that doesn't change based on platform or other conditions. You can specify prerequisites for different phases and kinds of relationship...

RJBS/Dist-Zilla-6.008   (8 reviews) - 06 Oct 2016 01:37:05 GMT - Search in distribution

Dist::Zilla::Plugin::Prereqs::Soften - Downgrade listed dependencies to recommendations if present.

This module iterates "build", "require" and "test" dependency lists and migrates dependencies found in ".requires" and demotes them to ".recommends" Optionally, it can duplicate softened dependencies to other locations...

KENTNL/Dist-Zilla-Plugin-Prereqs-Soften-0.006002 - 01 May 2016 18:06:47 GMT - Search in distribution

Dist::Zilla::Plugin::Git - Update your git repository after release

This set of plugins for Dist::Zilla can do interesting things for module authors using Git (<http://git-scm.com>) to track their work. You need Git 1.5.4 or later to use these plugins. Some plugins require a more recent version of Git for certain fea...

ETHER/Dist-Zilla-Plugin-Git-2.041 - 16 Nov 2016 03:38:28 GMT - Search in distribution

Dist::Zilla::Plugin::OptionalFeature - Specify prerequisites for optional features in your distribution

This plugin provides a mechanism for specifying prerequisites for optional features in metadata, which should cause CPAN clients to interactively prompt you regarding these features at install time (assuming interactivity is turned on: e.g. "cpanm --...

ETHER/Dist-Zilla-Plugin-OptionalFeature-0.023 - 16 Mar 2016 18:49:01 GMT - Search in distribution

Dist::Zilla::Plugin::Breaks - Add metadata about potential breakages caused by your distribution

This plugin adds distribution metadata regarding other modules and version that are not compatible with your distribution's release. It is not quite the same as the "conflicts" field in prerequisite metadata (see "Relationships" in CPAN::Meta::Spec),...

ETHER/Dist-Zilla-Plugin-Breaks-0.004 - 19 Aug 2016 00:48:28 GMT - Search in distribution

Dist::Zilla::Plugin::Prereqs::Plugins - Add all Dist::Zilla plugins presently in use as prerequisites.

This is mostly because I am lazy, and the lengthy list of hand-updated dependencies on my @Author:: bundle started to get overwhelming, and I'd periodically miss something. This module is kinda "AutoPrereqs"y, but in ways that I can't imagine being p...

KENTNL/Dist-Zilla-Plugin-Prereqs-Plugins-1.003002 - 10 Apr 2015 04:16:45 GMT - Search in distribution

Module::Runtime::Conflicts - Provide information on conflicts for Module::Runtime

This module provides conflicts checking for Module::Runtime, which had a recent release that broke some versions of Moose. It is called from Moose::Conflicts and "moose-outdated"....

ETHER/Module-Runtime-Conflicts-0.003 - 23 Jun 2016 03:48:42 GMT - Search in distribution

Dist::Zilla::Plugin::AssertOS - Require that our distribution is running on a particular OS

Dist::Zilla::Plugin::AssertOS is a Dist::Zilla plugin that integrates Devel::AssertOS so that CPAN authors may easily stipulate which particular OS environments their distributions may be built and installed on. The author specifies which OS or OS fa...

BINGOS/Dist-Zilla-Plugin-AssertOS-0.06 - 04 Oct 2013 21:17:05 GMT - Search in distribution

Dist::Zilla::Plugin::ReadmeFromPod - dzil plugin to generate README from POD

This plugin generates the README from "main_module" (or specified) by Pod::Readme. Options The following options are supported: "filename" The name of the file to extract the README from. This defaults to the main module of the distribution. "type" T...

FAYLAND/Dist-Zilla-Plugin-ReadmeFromPod-0.35 - 19 Oct 2016 14:52:45 GMT - Search in distribution

Dist::Zilla::Plugin::Prereqs::Recommend::MatchInstalled - Advertise versions of things you have as soft dependencies

KENTNL/Dist-Zilla-Plugin-Prereqs-Recommend-MatchInstalled-0.003001 - 09 Sep 2014 14:18:20 GMT - Search in distribution

Dist::Zilla::Plugin::Prereqs::SyncVersions - (DEPRECATED) Homogenize prerequisites so dependency versions are consistent

This module exists to pose mostly as a workaround for potential bugs in downstream tool-chains. Namely, "CPAN.pm" is confused when it sees: runtime.requires : Foo >= 5.0 test.requires : Foo >= 6.0 It doesn't know what to do. This is an easy enough pr...

KENTNL/Dist-Zilla-Plugin-Prereqs-SyncVersions-0.003001 - 04 Feb 2015 09:50:10 GMT - Search in distribution

Dist::Zilla::Plugin::ModuleBuild::Custom - Allow a dist to have a custom Build.PL

This plugin is for people who need something more complex than the auto-generated Makefile.PL or Build.PL generated by the MakeMaker or ModuleBuild plugins. It is a subclass of the ModuleBuild plugin, but it does not write a Build.PL for you. Instead...

CJM/Dist-Zilla-Plugins-CJM-4.27 - 29 Aug 2015 21:10:16 GMT - Search in distribution