Lexical::SealRequireHints - prevent leakage of lexical hints

This module works around two historical bugs in Perl's handling of the "%^H" (lexical hints) variable. One bug causes lexical state in one file to leak into another that is "require"d/"use"d from it. This bug, [perl #68590], was present from Perl 5.6...

ZEFRAM/Lexical-SealRequireHints-0.010 - 18 Mar 2016 05:08:54 GMT - Search in distribution

Devel::Pragma - helper functions for developers of lexical pragmas

This module provides helper functions for developers of lexical pragmas (and a few functions that may be useful to non-pragma developers as well). Pragmas can be used both in older versions of perl (from 5.8.1), which had limited support, and in the ...

CHOCOLATE/Devel-Pragma-1.1.0 - 01 Jul 2016 13:40:31 GMT - Search in distribution

Module::Runtime - runtime module handling

The functions exported by this module deal with runtime handling of Perl modules, which are normally handled at compile time. This module avoids using any other modules, so that it can be used in low-level infrastructure. The parts of this module tha...

ZEFRAM/Module-Runtime-0.014   (1 review) - 06 Feb 2014 22:11:32 GMT - Search in distribution

Module::Runtime - runtime module handling

The functions exported by this module deal with runtime handling of Perl modules, which are normally handled at compile time. This module avoids using any other modules, so that it can be used in low-level infrastructure. The parts of this module tha...

TOBYINK/Alt-Module-Runtime-ButEUMM-0.001 - 19 Jun 2014 12:09:55 GMT - Search in distribution

Acme::require::case - Make Perl's require case-sensitive

This module overrides "CORE::GLOBAL::require" to make a case-sensitive check for its argument. This prevents "require foo" from loading "Foo.pm" on case-insensitive filesystems. It does not respect any prior "require" overrides, since it completely r...

DAGOLDEN/Acme-require-case-0.012 - 04 Feb 2014 19:08:55 GMT - Search in distribution