more than 999 results (0.627 seconds)
Perl::Version - Parse and manipulate Perl version strings 4 ++

Perl::Version provides a simple interface for parsing, manipulating and formatting Perl version strings. Unlike version.pm (which concentrates on parsing and comparing version strings) Perl::Version is designed for cases where you'd like to parse a v...

BDFOY/Perl-Version-1.013 - 12 Feb 2014 20:58:43 GMT - Search in distribution

Perl::PrereqScanner::Lite::Scanner::Version - Extra Perl::PrereqScanner::Lite Scanner for VERSION method 5 ++

Perl::PrereqScanner::Lite::Scanner::Version is the extra scanner for Perl::PrereqScanner::Lite. This scanner supports "VERSION" method. It retrieves version from the argument of "VERSION". For example, require Foo::Bar; Foo::Bar->VERSION(1.00); LICEN...

MOZNION/Perl-PrereqScanner-Lite-0.18 - 17 Apr 2014 07:00:47 GMT - Search in distribution

ModPerl::VersionUtil - Makes it easier to investigate your mod_perl version. ++

This module helps you to investigate your mod_perl version easily. METHODS is_mp Returns true if your application is running under mod_perl. is_mp1 Returns true if your mod_perl version is 1.0. is_mp19 Returns true if your mod_perl version is 1.9 whi...

NAOYA/ModPerl-VersionUtil-0.03 - 28 Dec 2006 06:02:49 GMT - Search in distribution

Perl::MinimumVersion - Find a minimum required version of perl for Perl code 12 ++

"Perl::MinimumVersion" takes Perl source code and calculates the minimum version of perl required to be able to run it. Because it is based on PPI, it can do this without having to actually load the code. Currently it tests both the syntax of your co...

NEILB/Perl-MinimumVersion-1.37   (3 reviews) - 11 May 2014 20:55:52 GMT - Search in distribution

Gentoo::PerlMod::Version - Convert arbitrary Perl Modules' versions into normalised Gentoo versions. ++
KENTNL/Gentoo-PerlMod-Version-0.6.0 - 27 Oct 2012 12:27:55 GMT - Search in distribution

Perl::MinimumVersion::Fast - Find a minimum required version of perl for Perl code 2 ++

"Perl::MinimumVersion::Fast" takes Perl source code and calculates the minimum version of perl required to be able to run it. Because it is based on goccy's Compiler::Lexer, it can do this without having to actually load the code. Perl::MinimumVersio...

TOKUHIROM/Perl-MinimumVersion-Fast-0.14 - 26 Mar 2014 03:00:54 GMT - Search in distribution

Log::Trace - provides a unified approach to tracing ++

A module to provide a unified approach to tracing. A script can "use Log::Trace qw( < mode > )" to set the behaviour of the TRACE function. By default, the trace functions are exported to the calling package only. You can export the trace functions t...

BBC/Log-Trace-1.070 - 24 Nov 2005 11:00:48 GMT - Search in distribution

App::SmokeBox::PerlVersion - SmokeBox helper module to determine perl version ++

App::SmokeBox::PerlVersion is a simple helper module for App::SmokeBox::Mini and minismokebox that determines version, architecture and OS version of a given "perl" executable. CONSTRUCTOR "version" Takes a number of arguments: 'perl', the perl execu...

BINGOS/App-SmokeBox-PerlVersion-0.16 - 29 Sep 2013 15:20:10 GMT - Search in distribution

MooseX::Types::PerlVersion - Perl::Version type for Moose classes ++

This package provides Moose types for Perl::Version. It also provides coercion from "Str" and "Num" Moose types. EXPORT None by default, you'll usually want to request "PerlVersion" explicitly. SEE ALSO Perl::Version Moose::Util::TypeConstraints Moos...

ROMANF/MooseX-Types-PerlVersion-0.002 - 06 Jun 2012 14:35:53 GMT - Search in distribution

App::SmokeBrew::PerlVersion - Moose role for perl versions ++

App::SmokeBrew::PerlVersion is a Moose::Role consumed by various parts of smokebrew that provides a required attribute and some methods. ATTRIBUTES "version" A required attribute. A Perl::Version object. Coerced from "Str" via "new" in Perl::Version ...

BINGOS/smokebrew-0.48   (1 review) - 18 Feb 2014 00:38:27 GMT - Search in distribution

Perl::Metrics::Plugin::MinimumVersion - Perl::Metrics plugin for Perl::MinimumVersion ++

This is a Perl::Metrics "plugin" that generated the two primary metrics generated by the Perl::MinimumVersion module. These are the minimum explicit perl version dependency, and the minimum syntax perl version dependency. While this is an actual plug...

ADAMK/Perl-Metrics-Plugin-MinimumVersion-0.02 - 02 Jun 2008 04:01:34 GMT - Search in distribution


VCS - Version Control System access in Perl ++

"VCS" is an API for abstracting access to all version control systems from Perl code. This is achieved in a similar fashion to the "DBI" suite of modules. There are "container" classes, "VCS::Dir", "VCS::File", and "VCS::Version", and "implementation...

ETJ/VCS-0.24 - 09 Jul 2014 05:14:22 GMT - Search in distribution

PAB3 - Perl Application Builder / Version 3 1 ++

"PAB3" provides a framework for building rapid applications with Perl. It includes a template handler for producing output. This part is defined here. Examples Following example loads a template from template1.tpx, does a loop over the %ENV variable ...

CHRMUE/PAB3-3.201 - 21 Oct 2009 21:02:12 GMT - Search in distribution
  • PAB3::CGI - CGI module for the PAB3 environment or as standalone
  • PAB3::Utils - Utility functions for the PAB3 environment or as standalone

Git - Perl interface to the Git version control system ++

This is the Git.pm from github's git/git, which is a mirror of the git source. I (cpan msouth, or current maintainer) update the VERSION string here, and maintain this little bit of POD. That's it. The only reason you would need this is if you are us...

MSOUTH/Git-0.03 - 13 Jan 2014 05:13:30 GMT - Search in distribution

version - Perl extension for Version Objects 12 ++

Version objects were added to Perl in 5.10. This module implements version objects for older version of Perl and provides the version object API for all versions of Perl. All previous releases before 0.74 are deprecated and should not be used due to ...

JPEACOCK/version-0.9908   (3 reviews) - 03 Feb 2014 12:28:51 GMT - Search in distribution

Gentoo::PerlMod::Version::FixEbuild - Automatically fix an old-style ebuild to a new style ebuild. ++
KENTNL/Gentoo-PerlMod-Version-FixEbuild-0.1.1 - 14 Jan 2011 05:23:40 GMT - Search in distribution

CPAN::Test::Dummy::Perl5::VersionQV - qv() version ++

CPAN::Test::Dummy::Perl5::VersionQV is a dummy CPAN distribution with the use of "qv()" in its VERSION line. AUTHOR Tatsuhiko Miyagawa <miyagawa@bulknews.net> COPYRIGHT Copyright 2013- Tatsuhiko Miyagawa LICENSE This library is free software; you can...

MIYAGAWA/CPAN-Test-Dummy-Perl5-VersionQV-v0.1.0 - 06 Aug 2013 05:51:42 GMT - Search in distribution

Marpa::PP - Pure Perl version of Marpa 1 ++

This is ALPHA software This is alpha software. There may be bugs. The interface may change. Please be careful. Do not rely on it for anything mission-critical. Overview Marpa parses any language whose grammar can be written in BNF. That includes recu...

JKEGL/Marpa-PP-0.014000 - 12 Mar 2012 16:41:21 GMT - Search in distribution

ppport.h - Perl/Pollution/Portability version __VERSION__ 5 ++

In order for a Perl extension (XS) module to be as portable as possible across differing versions of Perl itself, certain steps need to be taken. * Including this header is the first major one. This alone will give you access to a large part of the P...

WOLFSAGE/Devel-PPPort-3.24 - 09 May 2014 00:15:50 GMT - Search in distribution




Hosting generously
sponsored by Bytemark