6 results (0.305 seconds)
PerlX::Maybe - return a pair only if they are both defined 11 ++

Moose classes (and some other classes) distinguish between an attribute being unset and the attribute being set to undef. Supplying a constructor arguments like this: my $bob = Person->new( name => $name, age => $age, ); Will result in the "name" and...

TOBYINK/PerlX-Maybe-1.000   (1 review) - 27 Aug 2013 06:58:47 GMT - Search in distribution

PerlX::Maybe::XS - XS backend for PerlX::Maybe 1 ++

Nothing to see here; move along. SEE ALSO PerlX::Maybe. AUTHOR Toby Inkster <tobyink@cpan.org>. COPYRIGHT AND LICENCE This software is copyright (c) 2013-2014 by Toby Inkster. This is free software; you can redistribute it and/or modify it under the ...

TOBYINK/PerlX-Maybe-XS-1.001 - 21 Feb 2014 16:43:57 GMT - Search in distribution

PerlX::ArraySkip - sub { shift; @_ } ++

The "arrayskip" function returns the entire list it was passed as arguments, except the first. This is an entirely trivial function and can be written as: sub arrayskip { shift; @_ } The principle of TIMTOWTDI says that there are other ways of skippi...

TOBYINK/PerlX-ArraySkip-0.002 - 14 May 2013 09:44:59 GMT - Search in distribution

Carp::Assert - executable comments 2 ++

"We are ready for any unforseen event that may or may not occur." - Dan Quayle Carp::Assert is intended for a purpose like the ANSI C library assert.h <http://en.wikipedia.org/wiki/Assert.h>. If you're already familiar with assert.h, then you can pro...

NEILB/Carp-Assert-0.21   (2 reviews) - 25 Jun 2014 21:23:44 GMT - Search in distribution

Defaults::Modern - Yet another approach to modernistic Perl ++

for complete details on imported functionality. DESCRIPTION Yet another approach to writing Perl in a modern style. . . . also saves me extensive typing ;-) When you "use Defaults::Modern", you get: * strict and fatal warnings except for "once"; addi...

AVENJ/Defaults-Modern-0.008001 - 25 Jun 2014 00:59:06 GMT - Search in distribution

Dist::Zilla::Plugin::Author::Plicease::SpecialPrereqs - Special prereq handling ++

Some older versions of modules have problematic for various reasons (at least in the context of how I use them). This plugin will upgrade those prereqs to appropriate version they are 0, meaning any version. Moo Require 1.001000, which allows for non...

PLICEASE/Dist-Zilla-PluginBundle-Author-Plicease-1.53 - 06 Jul 2014 13:26:29 GMT - Search in distribution




Hosting generously
sponsored by Bytemark