Dist::Zilla::PluginBundle::Author::KENTNL - BeLike::KENTNL when you build your distributions. River stage zero No dependents

This is the plug-in bundle that KENTNL uses. It exists mostly because he is very lazy and wants others to be using what he's using if they want to be doing work on his modules....

KENTNL/Dist-Zilla-PluginBundle-Author-KENTNL-2.025021 - 04 Mar 2017 03:21:02 GMT

Dist::Zilla::PluginBundle::Author::KENTNL::Lite - (DEPRECATED) A Minimal Build-Only replacement for @Author::KENTNL for contributors. River stage zero No dependents

This is an attempt at one way of solving a common problem when contributing to things built with "Dist::Zilla". This is done by assuming that the code base that its targeting will NEVER be released in its built form, but close enough to the normal bu...

KENTNL/Dist-Zilla-PluginBundle-Author-KENTNL-Lite-2.001001 - 09 Mar 2017 15:17:32 GMT

Dist::Zilla::MintingProfile::Author::KENTNL - KENTNL's Minting Profile River stage zero No dependents

KENTNL/Dist-Zilla-PluginBundle-Author-KENTNL-2.025021 - 04 Mar 2017 03:21:02 GMT

Dist::Zilla::Plugin::Author::KENTNL::DistINI - Generate a dist.ini for @Author::KENTNL projects. River stage zero No dependents

KENTNL/Dist-Zilla-PluginBundle-Author-KENTNL-2.025021 - 04 Mar 2017 03:21:02 GMT

Dist::Zilla::Plugin::Author::KENTNL::MinimumPerl - The MinimumPerl Plugin with a few hacks River stage zero No dependents

KENTNL/Dist-Zilla-PluginBundle-Author-KENTNL-2.025021 - 04 Mar 2017 03:21:02 GMT

Dist::Zilla::Role::BundleDeps - Automatically add all plugins in a bundle as dependencies River stage one • 4 direct dependents • 5 total dependents

This role attempts to solve the problem of communicating dependencies to META.* from bundles in a different way. My first attempt was "[Prereqs::Plugins]", which added all values that are seen in the "dist.ini" to dependencies. However, that was inhe...

KENTNL/Dist-Zilla-Role-BundleDeps-0.002005 - 03 Mar 2017 11:01:53 GMT

Dist::Zilla::Util::BundleInfo - Load and interpret a bundle River stage one • 2 direct dependents • 4 total dependents

KENTNL/Dist-Zilla-Util-BundleInfo-1.001005 - 04 Mar 2017 04:26:58 GMT

Dist::Zilla::Plugin::Prereqs::Upgrade - Upgrade existing prerequisites in place River stage one • 1 direct dependent • 1 total dependent

This allows you to automatically upgrade selected prerequisites to selected versions, if, and only if, they're already prerequisites. This is intended to be used to compliment "[AutoPrereqs]" without adding dependencies. [AutoPrereqs] [Prereqs::Upgra...

KENTNL/Dist-Zilla-Plugin-Prereqs-Upgrade-0.001001 - 01 Mar 2017 22:58:36 GMT

Dist::Zilla::Role::PluginLoader - A Plugin that can load others. River stage one • 2 direct dependents • 2 total dependents

KENTNL/Dist-Zilla-Role-PluginLoader-0.001003 - 08 Mar 2017 09:46:45 GMT

Dist::Zilla::PluginBundle::Author::TABULO - A plugin bundle for distributions built by TABULO River stage zero No dependents

This is the plug-in bundle that TABULO uses for his distributions whose starting point was ETHER's. It exists mostly because TABULO is very lazy and wants others to be using what he's using if they want to be doing work on his modules, just like KENT...

TABULO/Dist-Zilla-PluginBundle-Author-TABULO-0.197 - 03 Jan 2018 01:49:27 GMT

Dist::Zilla::Plugin::MetaProvides::Update - A plugin to fix "provides" metadata after [RewriteVersion] modified $VERSION declarations River stage one • 5 direct dependents • 5 total dependents

This plugin is a hack and hopefully will soon be made redundant. It is bundled along with a (the?) bundle that needs it, but can also be used with other bundles if such a need is identified. This plugin is meant to be run after all other file mungers...

ETHER/Dist-Zilla-PluginBundle-Git-VersionManager-0.007 - 11 Apr 2018 03:45:47 GMT

Dist::Zilla::Plugin::Author::KENTNL::Prereqs::Latest::Selective - [DEPRECATED] Selectively upgrade a few modules to depend on the version used. River stage zero No dependents

This module is deprecated and no longer used by @Author::KENTNL Instead, he recommends you use "[Prereqs::MatchInstalled]"...

KENTNL/Dist-Zilla-Plugin-Author-KENTNL-Prereqs-Latest-Selective-1.001001 - 09 Mar 2017 08:11:58 GMT

12 results (0.065 seconds)