Search results for "module:Perl::Critic::Policy::Modules::PerlMinimumVersion"

Perl::Critic::Policy::Modules::PerlMinimumVersion - Enforce backward compatible code. River stage one • 4 direct dependents • 8 total dependents

As Perl evolves, new desirable features get added. The best ones seem to break backward compatibility, unfortunately. This policy allows you to specify a mandatory compatibility version for your code. For example, if you add the following to your .pe...

THALJEF/Perl-Critic-More-1.003 - 29 Oct 2013 16:43:05 UTC

Perl::Critic::Policy::Compatibility::PodMinimumVersion - check Perl version declared against POD features used River stage two • 5 direct dependents • 18 total dependents

This policy is part of the "Perl::Critic::Pulp" add-on. It checks that the POD features you use don't exceed your target Perl version as indicated by "use 5.008" etc. use 5.005; =pod C<< something >> # bad, double angles needs 5.006 POD doesn't affec...

KRYDE/Perl-Critic-Pulp-99 - 28 Feb 2021 08:34:14 UTC

Perl::Critic::Policy::Compatibility::PerlMinimumVersionAndWhy - explicit Perl version for features used River stage two • 5 direct dependents • 18 total dependents

This policy is part of the "Perl::Critic::Pulp" add-on. It requires that you have an explicit "use 5.XXX" etc for the Perl syntax features you use, as determined by "Perl::MinimumVersion". use 5.010; # the // operator is new in perl 5.010 print $x //...

KRYDE/Perl-Critic-Pulp-99 - 28 Feb 2021 08:34:14 UTC
3 results (0.057 seconds)