NAME

Apache2::CGI::Builder - CGI::Builder and Apache/mod_perl2 (new namespace)integration

VERSION 1.3

The latest versions changes are reported in the Changes file in this distribution. To have the complete list of all the extensions of the CBF, see "Extensions List" in CGI::Builder

INSTALLATION

Prerequisites
    Apache/mod_perl2  (PERL_METHOD_HANDLERS enabled)
    CGI::Builder >= 1.2
CPAN
    perl -MCPAN -e 'install Apache::CGI::Builder'

You have also the possibility to use the Bundle to install all the extensions and prerequisites of the CBF in just one step. Please, notice that the Bundle will install A LOT of modules that you might not need, so use it specially if you want to extensively try the CBF.

    perl -MCPAN -e 'install Bundle::CGI::Builder::Complete'
Standard installation

From the directory where this file is located, type:

    perl Makefile.PL
    make
    make test
    make install

DESCRIPTION

Note: You should know CGI::Builder.

This module is the mod_perl2 compilant version of the Apache::CGI::Builder extension. Use it only if you have installed the official release of mod_perl 2 (Apache2::* namespace). Read the documentation in Apache::CGI::Builder.

SUPPORT

See "SUPPORT" in CGI::Builder.

AUTHOR and COPYRIGHT

© 2004 by Domizio Demichelis (http://perl.4pro.net)

All Rights Reserved. This module is free software. It may be used, redistributed and/or modified under the same terms as perl itself.

1 POD Error

The following errors were encountered while parsing the POD:

Around line 134:

Non-ASCII character seen before =encoding in '©'. Assuming ISO8859-1