Renee Baecker

NAME

Data::Validate::WithYAML::Plugin::PasswordPolicy - Plugin to check passwords against a policy

VERSION

version 0.02

SYNOPSIS

    use Data::Validate::WithYAML::Plugin::PasswordPolicy;

    my $foo = Data::Validate::WithYAML::Plugin::PasswordPolicy->check( 'mypassword' );
    ...
    
    # use the plugin via Data::Validate::WithYAML
    
    use Data::Validate::WithYAML;
    
    my $password  = 'mypassword';
    my $validator = Data::Validate::WithYAML->new( 'test.yml' );
    print "yes" if $validator->check( 'password', $password );
  
    # it allows extra params to define the policy
    my $password  = 'mypassword';
    my $validator = Data::Validate::WithYAML->new( 'test.yml' );
    print "yes" if $validator->check( 
        'password',
        $password,
        {
            'x-policy' => { length => '3,', chars => [ 'A-Z', 'def', '$§!', '\d' ] },
        }
    );

test.yml

  ---
  step1:
      password:
          plugin: PasswordPolicy
          type: required

SUBROUTINES

check

POLICY RULES

Those rules are allowed in the policy:

  • length

  • chars

  • chars_blacklist

AUTHOR

Renee Baecker <reneeb@cpan.org>

COPYRIGHT AND LICENSE

This software is Copyright (c) 2014 by Renee Baecker.

This is free software, licensed under:

  The Artistic License 2.0 (GPL Compatible)

1 POD Error

The following errors were encountered while parsing the POD:

Around line 113:

Non-ASCII character seen before =encoding in ''$§!','. Assuming UTF-8