HIROSE Masaaki
and 1 contributors

NAME

Devel::PatchPerl::Plugin::Legacy - patchperl plugin for EOL Perls

SYNOPSIS

    export PERL5_PATCHPERL_PLUGIN=Devel::PatchPerl::Plugin::Legacy
    perlbrew install 5.8.8 -Doptimize='-O2 -g'

DESCRIPTION

Devel::PatchPerl::Plugin::Legacy is a patchperl plugin for EOL Perls.

    5.8.[89]
    5.10.1
    5.12.5
      CVE-2013-1667 prevent hsplit DOS attacks
    5.8.8
      Do not add -DDEBUGGING (which enables internal debugging code) even if "-g" in -Doptimize

METHODS

Devel::PatchPerl::Plugin::Asan::patchperl($class, {version,source,patchexe})

Apply patches in Devel::PatchPerl::Plugin::Legacy depending on the perl version. See Devel::PatchPerl::Plugin.

AUTHOR

HIROSE Masaaki <hirose31 _at_ gmail.com>

REPOSITORY

https://github.com/hirose31/devel-patchperl-plugin-legacy

  git clone git://github.com/hirose31/devel-patchperl-plugin-legacy.git

patches and collaborators are welcome.

SEE ALSO

Devel::PatchPerl::Plugin

LICENSE

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself.