Robert Krimen
and 1 contributors

NAME

Dist::Zilla::Plugin::SurgicalPkgVersion - Surgically apply PkgVersion

VERSION

version 0.0019

SYNOPSIS

In your Dist::Zilla dist.ini:

    [SurgicalPkgVersion]

To hint that you want to apply PkgVersion:

    package Xyzzy;
    # Dist::Zilla: +PkgVersion

    ...

DESCRIPTION

Dist::Zilla::Plugin::SurgicalPkgVersion will only PkgVersion a .pm if:

    1. There exists an # ABSTRACT: ...
    2. The +PkgVersion hint is present

You can forcefully disable PkgVersion on a .pm by using the -PkgVersion hint

AUTHOR

Robert Krimen <robertkrimen@gmail.com>

COPYRIGHT AND LICENSE

This software is copyright (c) 2011 by Robert Krimen.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.