Rocco Caputo

sub skip_tests { my $test_name = shift; return "Gtk needs a DISPLAY (set one today, okay?)" unless ( defined $ENV{DISPLAY} and length $ENV{DISPLAY} ); return "Gtk tests require the Gtk module" if do { eval "use Gtk"; $@ }; return "Gtk init failed. Is DISPLAY valid?" unless defined Gtk->init_check; if ($test_name eq "z_rt39872_sigchld_stop") { return "Gdk crashes"; } return; }

NAME

POE::Loop::Gtk - a bridge that allows POE to be driven by Gtk 1.x

SYNOPSIS

See POE::Loop.

  use Gtk;
  use POE;

  # Rest of your program here.

DESCRIPTION

POE::Loop::Gtk replaces POE's internal event loop with the Gtk module. This allows programs to use both POE and Gtk 1.x at the same time.

Please see POE::Loop::Glib for more modern Gtk2 and Gtk3 support.

POE::Loop::Gtk implements the interface documented in POE::Loop. Therefore it has no documentation of its own. Please see POE::Loop for more details.

HELP WANTED

This project needs a developer or tester. Nobody can seem to get the Gtk dependency built to verify whether this event loop adapter works. Maybe you can?

BUGS

None known, but see "HELP WANTED".

SEE ALSO

POE, POE::Loop, Gtk, POE::Loop::Glib, POE::Loop::PerlSignals

AUTHORS & LICENSING

POE::Loop::Gtk is Copyright 1998-2013 Rocco Caputo. All rights reserved. POE::Loop::Gtk is free software; you may redistribute it and/or modify it under the same terms as Perl itself.




Hosting generously
sponsored by Bytemark