NAME

Paws::SSM::PatchSource

USAGE

This class represents one of two things:

Arguments in a call to a service

Use the attributes of this class as arguments to methods. You shouldn't make instances of this class. Each attribute should be used as a named argument in the calls that expect this type of object.

As an example, if Att1 is expected to be a Paws::SSM::PatchSource object:

  $service_obj->Method(Att1 => { Configuration => $value, ..., Products => $value  });

Results returned from an API call

Use accessors for each attribute. If Att1 is expected to be an Paws::SSM::PatchSource object:

  $result = $service_obj->Method(...);
  $result->Att1->Configuration

DESCRIPTION

Information about the patches to use to update the instances, including target operating systems and source repository. Applies to Linux instances only.

ATTRIBUTES

REQUIRED Configuration => Str

  The value of the yum repo configuration. For example:

[main]

cachedir=/var/cache/yum/$basesearch$releasever

keepcache=0

debuglevel=2

REQUIRED Name => Str

  The name specified to identify the patch source.

REQUIRED Products => ArrayRef[Str|Undef]

  The specific operating system versions a patch repository applies to,
such as "Ubuntu16.04", "AmazonLinux2016.09", "RedhatEnterpriseLinux7.2"
or "Suse12.7". For lists of supported product values, see PatchFilter.

SEE ALSO

This class forms part of Paws, describing an object used in Paws::SSM

BUGS and CONTRIBUTIONS

The source code is located here: https://github.com/pplu/aws-sdk-perl

Please report bugs to: https://github.com/pplu/aws-sdk-perl/issues