Rafaël Garcia-Suarez


ex::newest - look for newest versions of modules installed several times


use ex::newest;

use My::Module; # Load newest version present

no ex::newest;


With this pragma, when you try to load a module with use or require, all directories specified in @INC will be searched for occurences of this module, and the most recent version found will be loaded.

The versions of the installed modules are computed by using ExtUtils::MM_Unix::parse_version.


Doesn't work when @INC contains hooks. More generally, you shouldn't manipulate @INC directly when using this module, unless you know what you're doing.


Copyright (c) 2001 Rafael Garcia-Suarez. All rights reserved. This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.