Author image Masatoshi Mizuno
and 1 contributors

NAME

Egg::View::Mail::Mailer::CMD - Mail is transmitted by using the sendmail command.

SYNOPSIS

  package MyApp::View::Mail::MyComp;
  use base qw/ Egg::View::Mail::Base /;
  
  ...........
  .....
  
  __PACKAGE__->setup_mailer('CMD');

DESCRIPTION

It is Mailer system component to transmit mail by using the sendmail command.

Use is enabled specifying 'CMD' for the first argument of 'setup_mailer' method.

CONFIGURATION

cmd_path

PATH of sendmail command.

It is set if the whereabouts of '/usr/sbin/sendmail', '/usr/local/sbin/sendmail', '/usr/bin/sendmail' is confirmed and it is found at the unspecification. The exception is generated when not found anywhere.

cmd_option

Start option to pass to command line.

Default is '-t -i'.

email_regexp

Regular expression for easy format check in mail address.

This stays in an easy check so that there is no obstacle to pass the mail address to the command line. Please check the check on the format of a detailed mail address beforehand by the module such as Email::Valid.

Default is '^[\w\d\-_]+@[\w\d\.\-_]+$'.

Moreover, it is possible to check it there making 'Valid_to_address' method for the MAIL controller. Please look at the source code in detail.

debug

It operates by debug mode.

When an effective value is given, the content of mail comes to be sent to 'debug_out' of the project without doing actual Mail Sending.

It tried to send the content of what mail by outputting 'debug_out' can be checked.

METHODS

mail_send ([MAIL_DATA_HASH])

This method is what 'send' method of Egg::View::Mail::Base calls it internally.

The obstacle is generated by operating the component built in when calling directly.

SEE ALSO

Egg::Release, Egg::View::Mail, Egg::View::Mail::Base, Egg::View::Mail::Mailer::SMTP,

AUTHOR

Masatoshi Mizuno <lushe@cpan.org>

COPYRIGHT AND LICENSE

Copyright (C) 2008 Bee Flag, Corp. <http://egg.bomcity.com/>, All Rights Reserved.

This library is free software; you can redistribute it and/or modify it under the same terms as Perl itself, either Perl version 5.8.6 or, at your option, any later version of Perl 5 you may have available.