NAME

Dist::Zilla::Plugin::Author::Plicease::SpecialPrereqs - Special prereq handling

VERSION

version 2.58

SYNOPSIS

 [Author::Plicease::SpecialPrereqs]

DESCRIPTION

Some older versions of modules have problematic for various reasons (at least in the context of how I use them). This plugin will upgrade those prereqs to appropriate version if they are 0, meaning any version.

Some modules are recommended if certain modules are already prerequisites. For example, XS modules may be recommended if otherwise pure perl modules will optionally use them.

This plugin also enforces that releases are not done on Perl 5.8 or MSWin32.

This plugin also adds a preface to your Makefile.PL or Build.PL to test the Perl version in a way that will not throw an exception, instead calling exit, so that they will not be reported on cpantesters as failures. This plugin should be the last Dist::Zilla::Role::InstallTool plugin in your dist.ini.

Moo

Require 2.x as this fixes the bug where fatal warnings was enabled.

PerlX::Maybe

Require 0.003

AnyEvent::Open3::Simple

Require 0.76 for new stdin style Require 0.83 for deprecation removals

Path::Class

Require 0.26 for spew

Mojolicious

Require 4.31

Role::Tiny

Require 1.003001. See rt#83248

JSON::XS

Recommended if JSON is required.

PerlX::Maybe::XS

Recommended if PerlX::Maybe is required.

EV

Recommended if Mojolicious or AnyEvent modules are required.

Test::Exit

Require 0.11 for dealing with exit inside and eval.

SEE ALSO

Dist::Zilla
Dist::Zilla::PluginBundle::Author::Plicease

AUTHOR

Graham Ollis <plicease@cpan.org>

COPYRIGHT AND LICENSE

This software is copyright (c) 2012,2013,2014,2015,2016,2017,2018,2019,2020 by Graham Ollis.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.