Changes for version 0.05 - 2020-09-01

  • VIM compatibility layer fixes
  • Require perl 5.22 or newer
  • Added VIMCompat methods:
    • Blob

Modules

Perl bindings for neovim
Neovim Buffer class
Neovim Buffers class
Common functions
Neovim Current class
ErrorResponse exception class
Neovim Funcs class
Neovim LuaFuncs class
Neovim MessagePack RPC class
Neovim::Ext::MsgPack::RPC::AsyncSession class
Neovim::Ext::MsgPack::RPC::EventLoop class
Neovim::Ext::MsgPack::RPC::Response class
Neovim::Ext::MsgPack::RPC::Session class
Neovim::Ext::MsgPack::RPC::Stream class
Neovim Plugin class
Neovim Plugin::Host class
Neovim Legacy perl Plugin
Neovim Buffer range class
Neovim Remote class
Neovim RemoteApi class
Neovim RemoteMap class
Neovim RemoteSequence class
Neovim Tabpage class
Tie STDOUT/STDERR
Neovim legacy VIM perl compatibility layer
Neovim legacy VIM perl compatibility layer
Neovim legacy VIM perl compatibility layer
Neovim Window class